SMS delivery reported delays

Incident Report for Trusona

Resolved

The issue with our SMS Service Provider is resolved. If you observe any issues, please contact us at support@trusona.com. Thanks.
Posted Apr 03, 2025 - 03:31 UTC

Monitoring

Our SMS Service Provider is noting some delays in the SMS delivery service. We are monitoring it and will post key updates, as they become available.
If you have any observations to share, please let us know at support@trusona.com. Thanks.
Posted Apr 02, 2025 - 18:30 UTC
This incident affected: Trusona Solutions (Account Take over (ATO) Protect).