Trusona mobile app version 4.28 for Android crashing
Incident Report for Trusona
Resolved
The new Android App release 4.28.1 available in the Play Store mitigates the reported issue. Please upgrade to this release.

Marking this incident closed. If you have any questions, concerns or related observations, please drop us a note to support@trusona.com.

Thanks for your patience, and apologies for the inconvenience.
Posted Jul 18, 2024 - 17:22 UTC
Monitoring
We have a new Android App release 4.28.1 available in the Play Store which should mitigate the reported issue. Please advise your impacted users to upgrade to release 4.28.1 immediately. Thanks.

If you have any questions, concerns or related observations, please drop us a note to support@trusona.com.
Posted Jul 18, 2024 - 17:05 UTC
Update
Apologies, but it appears that just reverting to the prior Android version 4.27 will also not work successfully after this crash on version 4.28. We will research a good method/process to fall back to prior version as a workaround and advise at the earliest. Thanks for your patience.
Feel free to email support@trusona.com with any other concerns or observations you may have to share. Thanks.
Posted Jul 18, 2024 - 14:14 UTC
Investigating
It has been reported that our latest Mobile App version 4.28 for Android is crashing. We are currently investigating and will provide a fix soon. In the meantime, please revert to the prior version 4.27 which is working fine.
Note that there are no issues on the iOS version of the App; this is for the Android version only.
Posted Jul 18, 2024 - 14:02 UTC
This incident affected: Trusona Solutions (Mobile App-based Authentication Service).