ATO Protect - Service degradation in the Geo-location services

Incident Report for Trusona

Resolved

This issue is now resolved. The GPS location should be rendered properly in the ATO Protect workspace now. Thanks for your patience. If you have any related observation, please contact support@trusona.com.
Posted Aug 19, 2025 - 16:45 UTC

Identified

We have identified a service degradation in ATO Protect's geo-location services. The user's GPS locations are not being displayed on the map. We are actively working to identify the root cause and resolve it quickly.
Posted Aug 19, 2025 - 15:07 UTC
This incident affected: Trusona Solutions (Account Take over (ATO) Protect).