ATO Protect - Impact due to AWS Issues

Incident Report for Trusona

Resolved

AWS reported their issues fully resolved as of 5:07 PDT / 8:07 EDT.

Thanks for your patience.

- Trusona Support
support@trusona.com
Posted Sep 04, 2026 - 02:41 UTC

Identified

AWS West Region (Oregon) is experiencing issues with some of their services. This may impact our ATO Protect services as well.

For now, the only known impact is delay in SMS delivery. Please wait and confirm if the user received the SMS, even if you see the "SMS not delivered" warning.

We are continuing to monitor the situation as it develops at AWS.

If you observe any other issues, please contact support@trusona.com.

thanks,
Trusona Support
Posted Sep 03, 2026 - 22:34 UTC
This incident affected: Trusona Solutions (Account Take over (ATO) Protect).